Arista – Multiple Chassis Agregation

7050Series10 40

 

I am posting a config on a set of Arista switches which utilise mLag which is basically multichassis link aggregation. This allows you to have a host or device connected to two seperate switches and it allows you to cover the hosts for redundancy. <p>&nbsp;</p>

Normally if you attach a device for redundancy to two switches spanning tree will block the alternative port. Mlag bypasses this as it sees the swiching area as a single domain or virtual switch.

 

Anyway, lets look at the config, I am taking to defaulted switches – two 24 port 7050 10GBE switches. I will be using port 22 and 23 as port channels, and i will use these as peer links. The Peer link is important as it shares domain information and maintains a heartbeat between the switches. Im not going over the basic config of the switch like management IP etc, i assume you have configured this already.

 

First we configure the peer link for mlag, this creates a local interface and associates it to the trunk group for the peer link. STP is disabled for this link

 

Switch01 –

interface ethernet 22-23
channel-group 102 mode active
interface port-channel 101
switchport mode trunk
switchport trunk group m01peer
exit

Switch02 –

interface ethernet 22-23
channel-group 101 mode active
interface port-channel 101
switchport mode trunk
switchport trunk group m02peer
exit

 

Next we can configure VLAN for the mlag heartbeat and communication.

 

Switch01 –

vlan 4094
trunk group mlag01
interface vlan 4094
ip address 10.0.0.1/30
no autostate
exit
no spanning-tree vlan 4094

Switch02 –

vlan 4094
trunk group mlag02
interface vlan 4094
ip address 10.0.0.4/30
no autostate
exit
no spanning-tree vlan 4094

 

Lastely we can configure the peer links for the machines you want to connect to the mlag environment.

 

Switch01 –

interface ethernet 1
description SW01_Machine01
channel-group 1 mode active
interface port-channel 1
mlag 1
exit

interface ethernet 2
description SW01_Machine02
channel-group 2 mode active
interface port-channel 2
mlag 2
exit

interface ethernet 3
description SW01_Machine03
channel-group 3 mode active
interface port-channel 3
mlag 3

Switch02 –

interface ethernet 1
description SW02_Machine01
channel-group 1 mode active
interface port-channel 1
mlag 1
exit

interface ethernet 2
description SW02_Machine02
channel-group 2 mode active
interface port-channel 2
mlag 2
exit

interface ethernet 3
description SW02_Machine03
channel-group 3 mode active
interface port-channel 3
mlag 3

 

Once you can completed this you can test the system and config by checking the mlag.

 

Switch1#

show mlag

MLAG Configuration:

domain-id :

local-interface :

peer-address :

peer-link :

MLAG Status:

state :

peer-link status :

local-int status :

system-id :

MLAG Ports:

Disabled

Configured :

Inactive :

Active-partial :

Active-full :

 

 

 

mlag

Vlan4094

10.0.0.2

Port-Channel101

 

Active

Up

Up

02:1c:FF:00:15:38

 

0

3

0

0

3

 

3 Comments

Leave a Reply to architectonics Cancel reply

Your email address will not be published. Required fields are marked *